找回密码
 立即注册

QQ登录

只需一步,快速开始

开启左侧

N76E003之CLK上拉问题

[复制链接]
hfei 发表于 2020-9-23 11:50:22 | 显示全部楼层 |阅读模式
N76E003将P02(CLK)引脚配置为上拉端口,且该引脚处于悬空状态。主要是用该引脚作为遥控学习控制端口,引脚为低电平时进入学习状态,平时在上拉作用下为高电平。
最近发现一奇怪现象,通过P16(DAT)引脚置高电平控制P07引脚输出,反复操作P16引脚连接的开关,即改变P16电平,多次操作开关后P07无反应,此时测量一下P02引脚电压5V,P07立即恢复输出,偶尔也不恢复,此时测得P02引脚电压2.9V左右,反复研究没搞明白这是什么原因所致?望各位给予指点,谢谢!

端口配置

端口配置

回复

使用道具 举报

匿名  发表于 2020-9-23 14:56:29
您的后半段描述有点歧义,麻烦您重新描述下,另外方便的话可否把代码全部贴出来,好分析问题
回复 支持 反对

使用道具

 楼主| hfei 发表于 2020-9-23 15:29:35 | 显示全部楼层
P02配置为上拉模式,P02_Quasi_Mode;//准双向口  P02=1;//弱上拉,且端口悬空,没有接任何外围电路,主要用于将该引脚拉低时进入指定程序模式。现在发现P02引脚电压有时5V,有时3V左右,不是应该一直为5V吗?怎么会出现上述问题呢?烦请指点,谢谢!

代码中P02就一个读取判断操作 搜狗截图20200923152823.jpg ,很基本的操作呀
回复 支持 反对

使用道具 举报

 楼主| hfei 发表于 2020-9-23 15:44:01 | 显示全部楼层
用示波器监测P02,发现无规律从5V一下子变成3V
回复 支持 反对

使用道具 举报

 楼主| hfei 发表于 2020-9-23 15:46:47 | 显示全部楼层
奇怪的是外部没有电路,不能分压,3V怎么来的呢
回复 支持 反对

使用道具 举报

 楼主| hfei 发表于 2020-9-23 15:55:19 | 显示全部楼层
现在发现P02的3V来自P03,P03电阻分压。也搞不懂为什么会跟随P03电压变化呢?P02上面的电压是无规律的一下子从5V变成跟随P03电压。是一下子跳变过来,不是慢慢变化下来的
回复 支持 反对

使用道具 举报

匿名  发表于 2020-9-23 16:16:55
麻烦您测下VDD的电压
您的仿真器是否接在P02上了
你有代理商吗,请让代理商联系新唐原厂解决.
回复 支持 反对

使用道具

 楼主| hfei 发表于 2020-9-23 16:22:58 | 显示全部楼层
谢谢您的回复,我没有用仿真器,是直接工作测试的,VDD工作电压5V稳定的,好的,我再找找原因,实在不行找代理商咨询一下。
回复 支持 反对

使用道具 举报

 楼主| hfei 发表于 2020-9-23 16:23:54 | 显示全部楼层
游客 112.64.146.x 发表于 2020-9-23 16:16
麻烦您测下VDD的电压
您的仿真器是否接在P02上了
你有代理商吗,请让代理商联系新唐原厂解决. ...

谢谢您的回复,我没有用仿真器,是直接工作测试的,VDD工作电压5V稳定的,好的,我再找找原因,实在不行找代理商咨询一下。
回复 支持 反对

使用道具 举报

高级模式
B Color Image Link Quote Code Smilies |上传

本版积分规则

新唐MCU